2022-02-25 18:50:54 +01:00

28 lines
690 B
Bash

# Maintainer: Edgar <Edgar{at}AnotherFoxGuy.com>
# Contributor: Canony <canony@protonmail.ch>
# Contributor: Caleb Maclennan <caleb@alerque.com>
pkgname=btop
pkgver=1.2.3
pkgrel=1
pkgdesc='A monitor of system resourecs, bpytop ported to C++'
arch=(x86_64 aarch64)
url="https://github.com/aristocratos/$pkgname"
license=(Apache)
depends=(coreutils sed )
makedepends=(build-essential gcc-10 g++-10)
_archive="$pkgname-$pkgver"
source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('8348bb37b642bf899b5ce0850d64e12cf9671c8c9624f3d21b58a015cd502107')
build() {
cd "$_archive"
make CXX=g++-10 all
}
package() {
cd "$_archive"
make DESTDIR="$pkgdir" PREFIX=/usr install
}